View Single Post
  #8 (permalink)  
Old 10th May, 2013, 05:32 AM
TrevorS TrevorS is offline
Member
 
Join Date: November 2002
Posts: 964

Quote:
Originally Posted by TrevorS View Post
Behavior with a PATA/SATA adapter between the motherboard secondary IDE interface (adjacent the DIMMS) and the new optical drive may actually be worse than before (couldn't read anything at all), but is definitely not better. Next up is motherboard BIOS change, question being whether it changes behavior of the SB SATA ports when used with the LG DVD/CD drive. The current BIOS and motherboard works, but is that because of the BIOS or the motherboard?
This operation has not only taken far more time than expected, but is still in progress. As far as BIOS version goes, the latest on ASUS site (build date 11/14/05) definitely allows a SATA optical drive in one of the VIA VT8237 controller ports. I used the ASUS install disc for the SB drivers and the optical drive behaves normally. I don't know if it can support one in each SATA port, but I do know it doesn't support a single hard drive -- guess that's where VIA drew the line.

So, I used Device Manager to uninstall all the RAID drivers (VIA and Promise) and installed afresh using the ASUS CD for the VT8237 and the latest Promise RAID drivers from the ASUS site into the gamer. Hooked the optical drive up to an SB SATA port and was able to auto start and play a movie, excellent ! However, before returning to the gamer, I broke down and tried the DVD/CD drive in my core PC and it not only didn't work, but it caused the system to crash during boot (happens during the Windows XP splash screen early in the boot process) -- I'm guessing it's during VT8237 driver initialization. I tried the same driver replacement procedure and behavior didn't change.

So, for a brief time, I had the new DVD/CD drive installed and working correctly via SATA in the target system, but now it's pulled again and I'm trying to find a solution to the core PC problem. It actually BSDs, but the banner immediately wipes it and the system reboots so I've no chance to read it. I tried running viasata.exe on both the core and the rebuild, but got the same results for both (DVD/CD drive installed) -- Reset PASS, PIO FAIL, DMA FAIL. The FAILs don't look too good, but the drive functions properly on that rebuilt machine, so nothing proven wrong.

Only thing that makes sense to me is either the VT8237 is defective, its BIOS is defective, or there's still something amiss with the driver. The driver install package includes the BIOS, though it's not clear to me whether setup actually installs it. Guess I'll try some more -- makes me wonder if that Asrock blowup is perhaps driver related?

If anyone has any ideas on this, I'd be happy to hear them !
__________________
FIC VA-503+
K6-III+/450@550
256MB PC133Turbo
Abit Rocket 100
WinXPsp2/Win98SE

Last edited by TrevorS; 10th May, 2013 at 05:34 AM.
Reply With Quote