AOA Forums

AOA Forums (http://www.aoaforums.com/forum/)
-   AMD Motherboards & CPUs (http://www.aoaforums.com/forum/4-amd-motherboards-and-cpus/)
-   -   Looking at building an APU based theater PC (http://www.aoaforums.com/forum/amd-motherboards-and-cpus/51264-looking-building-apu-based-theater-pc.html)

TrevorS 23rd November, 2013 09:44 AM

Looking at building an APU based theater PC
 
I've never had a home theater PC, never really had the need, but since I'm getting to have a fair number of media files on my "server", seems like it would be a good idea to tie it into my big screen somehow. I've got a few older PCs around, but I'm suspecting for 1280p, none of my AGP cards would be able to accelerate the modern codecs and I know they don't support HDMI.

That leaves either buying a PCIe mainboard, processor, and probably an HD 7750 video card, or going with an FM2 mATX board and APU -- a cheaper solution. So, seems a good opportunity to get my feet wet with APUs :)!

Just ordered a used A6-5400K Trinity which I think should be fine for movie playback through 1280p (not 4000p). Am looking at the affordable Gigabyte F2A88XM-HD3 and ASRock FM2A88M-HD+ which allow eventual upgrade to Kaveri. So, that would get me in for about $200 including 4GB DDR3 1600 and a refurb hard drive. Course, I also need to figure out where to put the darned thing and how to connect it to my LAN, but seems an interesting project.

Any inputs/suggestions from people who've installed home theater PC's?

danrok 23rd November, 2013 03:52 PM

For LAN, have you looked at using a Powerline adapter?
Newegg.com - TP-LINK TL-PA2010KIT AV 200Mbps Nano Powerline Adapter Starter Kit

Better than running cables through the house, and enough bandwidth for video.

TrevorS 23rd November, 2013 06:59 PM

Not bad, and a reasonable price! Not sure whether I'd want to keep that form of connection (I like the security of hardwire), but would certainly be flexible while trying things out and finalizing layout. Just dropped one in my basket -- thanks :)!

TrevorS 7th December, 2013 03:47 PM

Finished building the HTPC Friday. It's a micro ATX board in a micro ATX case and has piles of space inside, almost cute :)! Came up pretty quickly, just two errors to correct. At power on the CPU fan wasn't starting because I'd misaligned the connector when plugging it in. The power on and HDD activity LED's weren't operating since I had the connectors backwards. Instead of installing the HSF provided with the A6 APU, I installed one intended for 95W FX series processors, it's about twice as tall for double the fin area (installed my 95W FX processors with 125W HSF w/ heat pipes -- want 'em cool.) Last time I checked, closed case APU temp was 27C with board temp 18C and room temp 14C (57F).

Ended up going dual boot with Win7 Ultimate 64bit in the first 20GB of the 250GB HDD, Mint 15 64bit in the final ~28GB, and the center ~200GB shared access FAT32. Do have a question regarding Mint. I installed a video card after the OS's and for Win7 that just meant I needed to run the install utilities! However, I don't see an analogous approach for Mint. Do I have to reformat the Mint partitions and reinstall to pick up whatever drivers Mint has for the Sound Blaster X-FI card? I'm thinking yes!

By the way, as indicated earlier, I've installed 4GB DDR3 1600. Given I plan to use this only for feeding media to a screen (no gaming), is there any good reason for bumping it to 8GB? Think I read some place that 4GB is fine for an HTPC.

PS. Reinstalled Mint 15 to make sure whatever drivers it had for my Creative Sound Blaster hardware were installed.

TrevorS 8th December, 2013 01:42 AM

As luck would have it, turns out the Creative audio card is defective (RMA assigned). Guess that tends to be what "refurb" means, clean up and repackage in hope of the next sap not noticing. Still, the installed HDD is also a refurb and it's working fine thus far (WD Blue 250GB, 720rpm, SATA3, 16MB cache.) As usual, there's something somewhere that doesn't quite work out :(!

booman 13th December, 2013 12:56 AM

Good call running Win 7 and Mint 15.
I run Win 7 and Mint 14... loving it!

No reason to get 8 Gigs of RAM unless you need it. RAM is cheap so it won't hurt.

Sucks the audio card is defunct! I hope the new one works in Windows and Linux

TrevorS 13th December, 2013 02:12 AM

Think I'm going to have to try 14.1 instead (14.1 32bit seems OK on my Pentium 4). 15 appears to be having troubles with the AMD A6 video, peculiar artifacts on screen, unless it's a 64bit Vs 32bit flaw. I'll have to try 64bit 14 and see what happens, yet another DVD burn :(!

Don't think there's probably a need for 8GB with a plain Jane HTPC (still trying to learn). I bought 8GB ddr3 1600 at a great price from NewEgg a couple weeks ago and now I'm trying to figure out why :p?

booman 13th December, 2013 01:41 PM

Yeah, or try Mint 16
You don't have to burn a DVD, they run and install just fine with USP flash drive.

TrevorS 20th December, 2013 11:09 PM

Thanks for the USB suggestion, something else for my box of tricks :)! I tried 14.1 and 16 (both 64bit) in Live mode and the problem remains, though 16 did a little better. The problem is that when I select the 'Menu' icon at bottom left, the window opens and I can select from the left side icons, but aside from the 'Accessories' button, the rest of the window content at best flashes, can't select anything. Also some streaks in the window. The only improvement with 16 was that the icons across the bottom tool bar were normal appearing, with 14.1 and 15 they're just splotches. Booted 16 Live on my FX4300 machine and it looked and behaved normal so they're just not fully APU compatible.

booman 20th December, 2013 11:22 PM

I just learned something new about Mint and Desktop Managers.
If you have older hardware, make sure to use Mint KDE Desktop Environment.
Otherwise Cinnamon is fine for modern hardware.

I was trying to install Mint 16 on an old Dell machine and Cinnamon crashed every time.
But KDE runs just fine.

robbie 21st December, 2013 05:20 PM

I know it's fun to build your own system and do all kinds of cool stuff with it, but if you just want a device that will play streamed media and just about anything you can throw at it, spend the $100 and get a Western Digital Live (live will stream from the network) media player. I have just a regular one (no streaming from the network) and I FREAKING love the thing. Just plug in a usb and it will play what ever is on it. Photo's, video's, and music. It just works and hooks up via HDMI.

booman 21st December, 2013 06:46 PM

Thats cool! I didn't know about the WD Live. Is it kinda like a small NAS?

TrevorS 21st December, 2013 09:39 PM

Thanks for the idea, the WD TV Live looks a pretty neat box, small size, decent price, includes a remote (I ordered a sale Rosewill Win7/8 remote a week ago for my HTPC -- hope it works.) However, spent a little time reading Newegg reviews and am not comfortable with the complaints. Think I may actually be safer staying with my HTPC and VLC, but don't know for sure yet.

Just got the new receiver working with the rest of the HT a couple days ago (still working on the main speaker cables, 22ft homemade buggers) and still have to try the power line LAN connection and using the HTPC to source the receiver. There's noticeable fan noise, so I think I'm going to move the rear fan ("Power") to the front fan header ("Case") since that one provides speed control. It shouldn't need much cooling in this job. Lot of things to test yet, see how far I get this weekend.

Quote:

Originally Posted by booman (Post 526078)
Sucks the audio card is defunct! I hope the new one works in Windows and Linux

Newegg reported receipt and acceptance of my RMA shipment Wednesday, but then Friday informed me of a refund. Guess they didn't have any more refurbed cards to send out. Still, the on-board Realtek sound is actually pretty good, and given I plan to use HDMI anyway, it probably won't be necessary. Does seem a little strange though not having a quality audio card in a media PC -- like something's missing. OTOH, doesn't hurt to have the $80 back in my checking account, it's been mostly outflow for awhile.

booman 22nd December, 2013 12:00 AM

Cool, let us know how HDMI works for you.

TrevorS 22nd December, 2013 09:13 AM

Cobbled it together tonight and suprisingly enough, everything works perfectly except the Win7 Desktop/VLC is slightly too large resulting in about 1/2-3/4" being cropped all the way round the 50" screen (interferes with navigation). According to the Control Panel, picture resolution is correctly set to 1080p and changing the TV image dimensions mode away from "FULL" makes it worse. Don't think there's any cropping of disc player video, at least, not apparent to me yet. Any idea what would cause this? Is there usually a trim adjustment somewhere to correct it?

TrevorS 23rd December, 2013 07:17 AM

Appears the problem was entirely due to TV overscan. Upon TV Menu correction, the Win7 Desktop ceased to be cropped. Much better :)!

booman 23rd December, 2013 07:20 PM

Awesome! Thanks for posting how you fixed it.
I would never have known it was TV overscan...

I have a pet-peeve with widescreen televisions because of all the different ratio's floating around out there.

It really sucks because I finally broke down and got a widescreen, but now I have black bars for almost every movie and TV show.

Somehow I was hoping widescreen televisions would have fixed this by now, but movies come in 16:10 and 16:9. I'm pretty sure my TV is 16:9 so all the 16L:10 movies have horizontal black bars.
Of course all the older TV shows are in 4:3 so I have no control over those.
But geesh, can we pick a standard?

TrevorS 23rd December, 2013 09:13 PM

As a film fan, black bars are normal to me. Films range from 1.37:1 (Academy Ratio) to 2.76:1. Many films are 1.85:1, normally being matted Academy. 16:9 is purely a compromise and usually only correct for HDTV broadcast or films that have been deliberately re-framed from the intended AR to 16:9 -- meaning that director intended film content has been discarded -- a no-no for a true film fan. My guess is the only movies that are genuinely 16:9 are those intended for HDTV broadcast.

widescreen.org - The Letterbox and Widescreen Advocacy Page

booman 23rd December, 2013 09:33 PM

That figures...
I would just like my whole screen to be filled with beautiful graphics instead of being smaller than intended.

I also have a projector and project my movies on a much larger screen. Letterbox doesn't bother me as much on that.

I would rather letterbox than cutting off content too, that is extremely annoying, specially when character's faces are cut off.

I even planned WAY ahead and made sure all of my DVD's were widescreen.
But its like every movie needs to be formatted for 3 different ratios so you can select the one your TV, Monitor, Projector supports.

TrevorS 23rd December, 2013 11:28 PM

Yeah, different strokes. For me movie integrity comes first (including original language), but for my elder brother, fully utilizing his playback equipment comes first. He objects to anything that doesn't fill the screen (paid for that viewing area, should be able to enjoy it), objects to B&W (paid for a color TV, should be in color), objects to subtitles (shouldn't have to read with TV, should be in English), he also objects to monaural (paid for stereo gear, should be in stereo), he'd probably object to lack of surround sound and ELF if he had the speakers for it. He bumped up to 48" LCD/LED a year ago and no longer minds as much about wider formats (sits very close), but still refuses to watch B&W or read subtitles.

Next steps with the HTPC are verifying the video color-space agrees with the players and figuring out how to use the Rosewill Windows remote control that just arrived. Would be nice if I no longer need to keep a keyboard and mouse attached. Should be enough to keep me busy for awhile :)!

booman 23rd December, 2013 11:43 PM

Oh man, I can't stand foreign movies without original language. When their mouth doesn't match up to the dialog... ugh, looks soo bad.

You can always get a mini keyboard with mousepad...
Newegg.com
I know its just more money, but gives you keyboard functionality and isn't huge.

TrevorS 24th December, 2013 02:42 AM

Thanks for the suggestion, but it would be nice if the remote can do the job. Just installed the driver and am realizing the design intent was to control Windows Media Center, something I've never used.

With Windows, it doesn't seem to have the ability to change window focus, but after arriving in a window (mouse), it can select objects, open and close folders, and playback a movie file. However, don't yet see a way to remote maximize the playback window, or move to a player control bar (probably window focus again) though the player control buttons appear to work.

I tried Windows Media Center, but instead of keeping my movie files organized for intelligent access, the stupid thing just stretched the names of every single media file across the screen and well beyond -- what good is that for more than a handful of files? I tried playing a DVD and control was fine, but the player wasn't. Windows Media Player image quality is junk, and unless WMC can be configured to playback with my choice of player, then it's junk as well. So, results of my initial foray aren't too good, though the remote itself works fine.

Just moved the HTPC back to the PC room to see if I can figure out any solutions. Not a good idea to lollygag with a PC on a plasma.

TrevorS 25th December, 2013 04:28 AM

Finding both the remote and WMC disappointing. I spent time searching setup hints for WMC and learned about streaming TV off the net from an older XP based article, but nothing in my Win7 Ultimate WMC indicates that capability is still available, only Live TV which I don't have and won't be getting. Spent time fooling around with the movie library mode and view it a pretty complete disaster. If I designate upper level directories, it says the subdirectories are included, but the titles don't show up. If I designate all the directories, they all show up and I've a 970+ entry nightmare extending well beyond the screen -- could hardly be more useless. Can find no way to navigate to a single directory and then down into its files. If it just allowed me to "TAB" from directory to directory, it would be a lot better, but still not good enough when dealing with TV series and even film extra content. Add to that the Windows Media Player picture is at best mediocre quality (it works, but that's it), I'm concluding the only thing good about WMC is it's compatible with the Rosewill remote. No wonder MS decided to start charging for it with Win8, what a great product!

For Windows Explorer, blowing up the size of the icons and screen print helps tremendously when navigating to a film, and the Remote supports navigation once the focus is in the server window. However, after launching film playback, I can't find a way to control screen size or exit playback outside of a mouse. Too bad the designers of the remote driver didn't allow for user programmability so it can also be setup to work reasonably with Windows.

Next step is to try XBMC and see if it makes any more sense. As an Open Source effort, seems at least likely it would support VLC playback. May even support the Remote. Wonder if it does a better job of organizing library files?

EDIT: XBMC may be the greatest thing since sliced bread, but I'm finding it pretty obtuse. Has a collection of net accessible transmissions which is good, but have got nowhere so far on accessing my server files, which is my main goal -- was expecting that to be pretty straightforward! Something to spend Christmas day with I suppose :(!

TrevorS 27th December, 2013 03:27 AM

As the day after Christmas winds to a close, XBMC is proving an uncrackable nut. I've learned it has its own playback software, meaning it doesn't support the only universal player I have confidence in -- VLC. Further, it appears the method I've been applying to try to get it to access my LAN film directories SHOULD work, but it isn't happening!

Latest annoyance is my attempt to register with their forum (hoping for help) has failed to result in the promised activation email. Am trying not to be too PO'd over this thing about which so many glowing words have been written, but with which I've thus far accomplished nothing (that includes a just-in-case system reinstall.) Even MS WMC could access my files, it just did a crummy job of handling, organizing, and presenting them!

Would be nice if I could at least see what the player output looks like so I'd know if all the getting-nowhere effort is worth it :(! However, to be fair, there are two positives I can point to -- a very nice GUI and apparent remote control compatibility.

TrevorS 27th December, 2013 11:59 PM

Latest XBMC news: they've just released a bug fix update 12.3, so I've removed 12.2 and installed the new. Unfortunately, no change. Found I can login to their forum, but when I try to post my problem, I'm told my account hasn't been activated. I entered my email address and requested resend, which it says it's done, but just as before, nothing has arrived (no, it's not in either my SPAM or TRASH bins). Getting the impression nobody is checking their contact email address, sent at least five so far. Maybe XBMC is just allergic to APUs, don't know, wonder if I'll ever be able to find out? Majorly bummed! :(

booman 30th December, 2013 01:57 PM

Wow, you have been busy.
I read the "about" page for XBMC and it describes exactly what you are trying to do, but obviously can't...
How sad is that?

Are you still testing all of this in Windows XP or Media Center?

Its almost comical because their description says " for use with televisions and remote controls. It allows users to play and view most videos, music, podcasts, and other digital media files from local and network storage media and the internet"

There should be a way to do this with VLC alone and Windows Explorer. But I"m sure you are looking for a simple software that will organize your movies and update when you add new one's. Then it should be browsable with a remote and small thumbnails.

Its sad because I have been using Windows Media Player for years to do this with Music. It creates little thumbnails of each album and I can rate them or categorize them. I can play whole albums and/or play a "radio station" with all of my music.

Why the heck can't it do it with movies? Oh wait... thats right... the stupid codecs.
You have to pay for MP4 codecs or rip everything as their WMP codec.

Its always about the money isn't it?

TrevorS 31st December, 2013 01:27 AM

The HTPC is running Win7 Ultimate Sp1. After the initial try I moved it upstairs and now have it hooked up next to the server with a KVM switch. Won't reconnect it to the receiver again until everything is ready to go. I'd be fine with Windows Explorer except I can't use the remote to change window focus or to make VLC go full screen or exit. That means I can't get away from the mouse and so I'd prefer to find something that works with the remote. WMC does, but that's the only thing I like about it.

Immediate problem with XBMC is I'm so far unable to access my server directories, yet they're fully shared and accessible. I access them regularly on my daily PC for upload and download. I've also accessed them via both WindowsExplorer and WMC from the HTPC (including playing part of a film and a DVD) while connected to the receiver.

Saturday I tried installing MediaPortal, another many like, and again got stymied. It searched out the directories just fine, but I couldn't figure out how to make it remember the ones I tried to select. I can only presume I'm making dumb goofs with both packages, but even "tutorials" haven't helped me, probably in part because they describe systems several revisions older and much has changed.

In any case, the XBMC people today manually activated my forum account so hopefully I'll be able to find out what I'm messing up.

TrevorS 31st December, 2013 11:06 AM

Turns out my XBMC problem revolved around the need to scroll a displayed menu, something I'm not used to. Probably just a reflection on me, but the important thing is I've finally been able to load XBMC with my server film inventory. Got to work with it more, but current appearances are good, and personally preferable to what I saw of WMC. I'll update as appropriate! :)

A remaining question is how XBMC video quality compares to WMC and VLC. Can't yet respond to that, but at least for me, it matters!

TrevorS 26th January, 2014 06:27 AM

Bit late updating this, but did some video comparisons and XBMC video quality is the easy winner over WMC. However, I also compared XBMC video (with setup tweaks) with the current release of VLC (2.1.2), and VLC won handily. Learned that XBMC video processing is the same as VLC except a generation behind due to XBMC release cycles. Tried the December XBMC Beta release and it give very similar image quality to the latest VLC. However, also learned there are certain other video solutions that can be better still. Am playing with one that's just like film to me, but have to work on the integration -- been distracted.

Should mention I made a mistake getting DDR3 1600 for my A6-5400K processor, should have gotten DDR3 1866 -- fastest the APU will support being the correct choice (primarily impacts iGPU speed). I've now 4GB 1866 on hand to install, will get there. :)

booman 26th January, 2014 05:52 PM

Thanks for the update. Keep at it, one can learn a lot from trial-n-error and making mistakes.

TrevorS 12th February, 2014 02:32 AM

Been battling with reception of the 2014 Sochi Olympics on my HTPC and have been learning a few things as a result. One is that my A6-5400K appears a capable over-clocker (runs at 4.4GHz w/o CPU over-voltage). Another is that my freshly purchased dual channel G. Skill 4GB DDR3 1866 "Rip Jaws" requires plenty of voltage (1.74V Vs 1.55V) to function correctly at 1866 -- disappointing, though also had to raise CPU voltage from 1.4000 to 1.4125V to successfully run Prime95 with the 1866. (G.Skill DDR3 1600 required neither.) Given a resulting memory clock of 933MHz, decided to bump the GPU clock from around 720 to some 1011 (appears stable at 950, but would prefer more margin.) Will probably have to run GPU benchmarks to see if GPU voltage is OK, but seems fine for Olympics stream broadcast.

In any case, after a few days of experimentation, I seem to be getting good Olympics reception and am happy for that! Am a consistent fan of the Winter Olympics -- go athletes, regardless of country!

Edit -- Darn, blue screened again, that blasted memory is too near the edge at 1866.

TrevorS 10th March, 2014 05:20 AM

Quote:

Originally Posted by TrevorS (Post 526360)
Been battling with reception of the 2014 Sochi Olympics on my HTPC and have been learning a few things as a result. One is that my A6-5400K appears a capable over-clocker (runs at 4.4GHz w/o CPU over-voltage). Another is that my freshly purchased dual channel G. Skill 4GB DDR3 1866 "Rip Jaws" requires plenty of voltage (1.74V Vs 1.55V) to function correctly at 1866 -- disappointing, though also had to raise CPU voltage from 1.4000 to 1.4125V to successfully run Prime95 with the 1866. (G.Skill DDR3 1600 required neither.) Given a resulting memory clock of 933MHz, decided to bump the GPU clock from around 720 to some 1011 (appears stable at 950, but would prefer more margin.) Will probably have to run GPU benchmarks to see if GPU voltage is OK, but seems fine for Olympics stream broadcast.

In any case, after a few days of experimentation, I seem to be getting good Olympics reception and am happy for that! Am a consistent fan of the Winter Olympics -- go athletes, regardless of country!

Edit -- Darn, blue screened again, that blasted memory is too near the edge at 1866.

FWIW -- My battle with G-Skill rip-jaws DDR3 1866 and stability has continued. Seems the supposed stock voltage of 1.55V and 1.62V just don't work for me, tried and tried and tried again. On the other hand, after multiple rounds of testing, it's appearing a voltage of 1.67v plus "auto" memory timing and a slight Northbridge increment (memory and graphics controller) may actually allow both cold boot and warmed Prime95 to perform. More testing needed, but at least it's hopeful. Will update accordingly!


All times are GMT +1. The time now is 05:09 PM.


Copyright ©2001 - 2010, AOA Forums


Search Engine Friendly URLs by vBSEO 3.3.0