AOA Forums

AOA Forums (http://www.aoaforums.com/forum/)
-   CRASHED! (http://www.aoaforums.com/forum/6-crashed/)
-   -   RAID 0+1 won't rebuild (http://www.aoaforums.com/forum/crashed/50948-raid-0-1-wont-rebuild.html)

troutcannon 15th November, 2012 04:51 AM

RAID 0+1 won't rebuild
 
Greetings to all. New member here. I joined because this looked like a good place for a seasoned tweaker to get help. Here goes:

I have an older ABIT KN9 Ultra with Nvidia 570 MCP running Nvidia Mediashield BIOS. The boot is a RAID 0+1 array with one HDD showing an error. Since this is a redundant array, the computer runs fine, but shows the array as degraded. I bought and installed an identical Seagate 750GB hard drive model. When I do this, I get no prompts for the array to begin rebuilding. I've also checked the array in BIOS, and nothing there. The POST screen still shows an error as well. I can "move" the error by swapping SATA cables, so I am sure I am working with the correct drive. What I can't get to work is the Nvidia Mediashield control panel. This is supposed to be integrated into the Nvidia Control Panel, but it isn't. I have also tried to run it as a separate application, but all I get is a status screen and no options for changing the array itself.

This is not critical....yet. If one more drive goes away, I could be hosed. The system may sound a little old, but it runs my ProE and Inventor CAD stuff very well. It even runs current games at 1920X1200, so it is not close to being ready for the junk heap.

Essentially, I believe the problem may be in the Nvidia BIOS or Mediashield app itself. I tried installing the latest V 15.46, but it doesn't work.

Anyway, this is long enough for a first post. I figured it would maybe generate some ideas or questions. Feel free to ask specifics related to diagnosing the problem. Any help is most appreciated. Nvidia service (from India) wasn't so helpful.


:banghead:

ThunderRd 15th November, 2012 06:39 AM

One thing is, if it's a boot array, it must be worked on outside the OS. That means accessing the RAID utility in the boot sequence. It can't be done in the OS RAID utility unless it's not a boot array. But I did not have success with it either when it happened to me.

I could be wrong, but I'm quite sure that if one drive fails in the 0+1 scenario, some of the mirrored component of the RAID is gone forever, and the array can't be rebuilt without it.

The advantage of 0+1 over RAID 0 is that the array continues to function, albeit in RAID 0 (with 3 drives). Of course, in RAID 0, the entire operability of the array is gone with any drive failure. And, for the record, this is why 1+0 is superior to 0+1. RAID 10 can be rebuilt, but your RAID controller may not support it, as many don't, unless they are high-end server boards.

It happened to me once, and I simply copied out the data, broke the array, created a new one with the new drive (so it returned to 4 drives) and then copied the data back. I did not have success attempting to rebuild the array, just like you.

Anyone who knows more than I do, feel free to correct :)

Aedan 15th November, 2012 10:48 AM

First thing first, as your array is degraded, ensure you have a backup before doing anything else, unless your data is completely disposable.

It is supposed to be as simple as replacing the hard disk, selecting the array in the mediashield BIOS, selecting the rebuild option and adding the new disk.

Now, doing it from the nvidia control panel app seems to indicate you need to delete the array first (!) - see Rebuilding a NVIDIA RAID Array for details. No promises this will work, as I no longer have an nVidia "RAID" controller, so I can't test it.

troutcannon 15th November, 2012 11:05 AM

Here's the rub
 
I was absolutely planning on making a backup with an Acronis image to a large WD Mybook external. Tried to install the latest build, and the installation fails.

I am extremely hesitant to delete the array. I've done this before, and it was exactly as you stated. Pop in the new drive and the rebuild proceeds. I still believe it is something related to the blasted Nvidia software.

I plan on trying to make an image with an older version of Acronis. I also plan on using a USB-SATA bridge to verify the new drive is in working order.

Thanks for the input!

:banghead:

ThunderRd 15th November, 2012 04:46 PM

I seem to have the wrong idea, then. The document is clear, and what I seem to remember from my own problem must not be correct.

All I know is, when this happened to me I was, likewise, not able to rebuild from the BIOS utility. As I said, I copied off the data, added the new drive, deleted and remade the array, and then copied the data back. It took forever to copy, but the operations were successful. If you can't get the rebuild to work, you could take this route. Good luck with it.

Hankenstein 20th November, 2013 02:29 AM

A raid 0+1 Array requires 4 hard drives, 2 are mirrored and 2 are striped, essentially 2 are mirror copies, and 2 are the main drives you are using. they are striped because data is spread between the 2 HDs. When 1 HD fails when booting you will get the message Array Degraded, as long as only 1 drive is degraded the array can be rebuilt without any data loss.

Gizmo 21st November, 2013 07:41 AM

Quote:

Originally Posted by ThunderRd (Post 521619)
I could be wrong, but I'm quite sure that if one drive fails in the 0+1 scenario, some of the mirrored component of the RAID is gone forever, and the array can't be rebuilt without it.

RAID 0+1 and RAID 1+0 are both redundant configurations, so as long as the array is simply degraded (and not offline) all of the data necessary to operate the array still exist.

RAID 1+0 is preferable to RAID 0+1, as RAID 1+0 gives you the same net performance, better degraded performance, and better fault tolerance: RAID 0+1 on 4 drives means that any single drive failure takes down the entire stripe and breaks the mirror (meaning only two drives are operational and there is NO redundancy), where RAID 1+0 on 4 drives can lose any single drive and still have both mirrors working. In addition, RAID 1+0 on 4 drives can tolerate ANY 2 drive failures and continue operating, where RAID 0+1 on 4 drives can tolerate 2 drive failures only under specific conditions (both failures occur in the same stripe).

Further, when recovering a degraded RAID 0+1, you have to rebuild the ENTIRE STRIPE, not just the failed drive, whereas with RAID 1+0, only the defective drive needs to be rebuilt.

Short story long, I see no valid reason to use RAID 0+1. :p

All that being said, the reason nVidia's tool doesn't let you rebuild the array is probably down to what I mentioned above: you have to rebuild the entire strip, and so nVidia's tool probably sees the whole thing as hopeless. As I have no personal experience with the tool, I can only speculate, however.


All times are GMT +1. The time now is 09:14 AM.


Copyright ©2001 - 2010, AOA Forums


Search Engine Friendly URLs by vBSEO 3.3.0