AOA Forums

AOA Forums (http://www.aoaforums.com/forum/)
-   EPoX MotherBoards (http://www.aoaforums.com/forum/27-epox-motherboards/)
-   -   SATA won't format, HELP!! (http://www.aoaforums.com/forum/epox-motherboards/24458-sata-wont-format-help.html)

KrayZeeZ 14th May, 2004 01:27 PM

SATA won't format, HELP!!
 
My Hitachi 80 GB won't format during xp install or in bios utility for a low level format. It will however format in partition magic, however, it did it nearly instantaneously. Never used PM before so i don't know how quick it should be. It's detected fine by bios and I loaded the neccessary drivers during windows install thru floppy disk. However it hangs in the format. I'm running an 8RDA3+ with a 3000+ barton w/ 400 fsb, 2 x512 corsair Twinx, 9600 pro, 400w Allied psu. couldnt get it to work so I installed xp on my western digital 120 GB (note I did not have this connected on first several attempts when installing XP onto SATA). Updated the driver via mobo cd. It shows up in device manager as "Disk drive" but it's not in explorer. Is there something else I need to do in Windows after installing the drivers? Also note that the silicon image bios utility would hang on a low level format. I still need to update the drivers to more current versions, but i mean, it still should be working now, right? Does this sound like a psu, mobo, or HD problem? I'm going to update bios today, hopefully that works, but I'm doubtful. Any advice is greatly appreciated.

oxyprazolam 14th May, 2004 01:42 PM

you have to partition the drive first. then format it....if the drive is new, or has been low-level formatted.

EPoX Tech 14th May, 2004 04:15 PM

1 Attachment(s)
You can try the attached BETA BIOS, but please do accept it's BETA status before flashing.

KrayZeeZ 15th May, 2004 01:16 AM

OK, my sata driver is working now. But it still, no matter what, will not format during XP install. The XP is legit. Formats fine once I'm running off my ide and format it in XP. Is there anyway I can just transfer XP to the SATA drive without reinstalling and whatnot since the install won't let me format in the first place.

EPoX Tech 15th May, 2004 08:22 AM

I see that you haven't d/l or tried the BETA BIOS......

betrayer 3rd June, 2004 04:08 AM

Hello, everybody.
I met the same problem as KrayZeeZ wrote in his article, I downloaded the bios and flashed it. But my SATA HDD still won't format.
Is there any other advice about this problem? Thanks in advance.

EPoX Tech 3rd June, 2004 07:41 AM

Are you trying to Quick format NTFS ?

betrayer 3rd June, 2004 10:02 AM

No, I am not. I tried to format in NTFS(Normal and Quick) and in FAT32(Normal and Quick) and it cannot finish. When I tried to format it with Partition Magic, it works but still cannot install Windows XP on it ( disk check or copy file failed ). And when I used it for data storage and copied some files, the system will occasionally stop responsing for a while. I just cannot figure out where the problem is.
BTW, I tested the HDD on another PC (with Celeron CPU and Intel Chipset) and it works properly, so it does not appear like HDD problem.

jnansley 4th June, 2004 01:31 AM

I've had random problems with installing XP on brand new hard drives with NF2 motherboards... I think I've got it figured out...

In each case, the symptom was a random "invalid boot disk" or "NTLDR missing" etc boot message, after a fresh XP install, whether or not "Quick" was used, whether or not Partionmagic was used. Also, XP setup would not use the entire disk for the partition (usually about 2GB short).

I believe the "Auto" setting in the BIOS was detecting the drive as CHS instead of LBA. (Or was it vice versa?)

In the first two cases, I solved the problem by installing Win98, and then installing XP (reformatting as NTFS, Quick or not).

In the last case, I figured out what was going on, and forced the drive to LBA (or was it CHS? ET should tell you the right answer). No problems, and once the drive was formatted/partitioned, then "Auto" worked properly.

betrayer 4th June, 2004 09:41 AM

The following is an article I found on Silicon Image's website saying about SiI3112A working with nForce Chipset:

Quote:

SiI3112A: nForce Data Corruption
Data corruption problems can occur with nForce-based motherboards such as the Asus A7N8X when multiple hard drives are attached to the SATA controller. This problem is related to an issue with the PCI controller in the nVidia chipset and can be fixed with a system BIOS update.

For the latest BIOS updates for your nForce motherboard that fixes the data corruption problem, please visit the website of your motherboard maker for the appropriate BIOS and flash utilities. Silicon Image cannot provide the solution to this issue since it involves a change to the system BIOS settings on the motherboard. There were no revisions made to the drivers for the SiI3112A so you may use the latest version posted on this website. Please check the Related Articles link on the lower right
.
Doesn't my problem look like this (I'm using two SATA HDDs to form RAID 0 set) ?
Will there be a new BIOS update for this? And if so, when will it be released?
P.S. This article was posted on Silicon Image's website at 3/24/2004.

KrayZeeZ 4th June, 2004 01:39 PM

Problem solved!!
 
I finally got XP to do a clean install on my SATA. I don't have raid running (yet) but it sounds like you were having the same problem as myself. There is a few things I did differently from my first unsuccessful attempt at doing a clean install of xp on the SATA so uinfortunately I don't know exactly what was causing the problem. Here's what I did differently...

After the first few unsuccessful formats during Win XP on the SATA I said screw it and put it on my ide. Then in Win XP I was able to do a full format of my SATA and everything read/wrote fine. I downloaded the newest siliconimage drivers from the www.epox.com/usa/ website 1.0.0.14 I think and put them on the driver disk that came with my mobo.

I then deleted the partition on the SATA with partition magic and turned off the IDE channel my IDE HD was running on (just disconnect it if it's on the same channel as ur CD-ROM). I performed the Win XP install doing a full NTFS format w/ the 1.0.0.14 drivers and no more errors. While I don't know for sure, I think it was the drivers that did the trick.

Since you are using RAID, make sure the sata bios has that set-up correctly. As an additional note, I didn't use the bios beta update posted earlier. I used the latest bios off the epox website. This was the same bios I was running during the unsuccessful installs tho. So it's not a bios issue I'd say...

So I'd suggest trying those drivers I mentioned first, then if that doesnt work, try to format ur raid in Win XP running off the IDE. Good luck!
btw...what brand sata are u using? (just curious, mine's Hitachi 80G from newegg)

piloteer81 4th June, 2004 04:50 PM

Not sure what the problem is here, I have the same board revision 2.1.
I'm also using hitachi sata 80 gig drives - 7k250's x2 in raid 0. Make sure you are using the latest 3112a sata driver available from http://www.siimage.com/
Also check your cables, obvious I know but sata's can pop out very easily.

If you are 'raiding' then create the array first in the post option then you'll need to set a partition on it. I just enter recovery console after booting from the XP CD and then type diskpart. Only then will you be able to format it.

Load the latest drivers onto a floppy and hold f6 down during XP unstall start u p, sure you know the score! Can't see you having any problems from there unless something has a headache in which case let us know!

KrayZeeZ 10th June, 2004 01:14 PM

OK...problem arose once again. I recently got another 80 gig SATA (same model) to run raid 0. Installed the new sata and formatted it from Win XP and made sure I could read/write from it. Everything checked out okay. I decided to try the beta bios since it supposedly improves the SATA performace. So I deleted both partitions thru partiion magic, rebooted and set-up the raid set thru serial bios and everything went fine. Began to install XP and it recognizes the raid set fine after loading the drivers (newest from epox website). I go to create two partitions from set-up. One 20 gig and one with the leftover ~140 GB. I choose to install on the 20 gig and choose a full NTFS format. format goes fine all the way up to 100%. Right after it seemed to complete windows tells me "windows can't format the selected partition...yada yada yada" just like before. You can imagine how PO'd I was then.

Anyway. I decided to try the format again, after deleting the raid set and recreating one. Still a no go the second time ( I also tried different partition sizes: 30 and ~130). Right after the second time of failing, before rebooting and trying something else, I decided to give a quick ntfs format a try. To my amazement it worked! Was supprised because when I was having the EXACT same problem with clean install of XP onto a single SATA, a quick format would yield the same error.

Anyway, my question is, is this a bad thing that I installed onto a partition that only had a quick format? It kinda had a full format I think because it did get to 100% when it failed. Do ya think this is gunna effect performace or stability? Both SATA's have had a full format before, but not after the raidset was made. And why the heck is this happening in the first place?

Gizmo 10th June, 2004 04:48 PM

A full format is done to give Windows a chance to find and map out any bad sectors that may exist on the drive. Thing is, it has been my experience that with modern drives, by the time you get to the point of the drive actually REPORTING those bad sectors to Windows, that drive is on a steep dive into oblivion. With new drives, there is no reason you should need to do a full format.

KrayZeeZ 11th June, 2004 02:10 PM

Well as I said I did get XP to install onto the RAID set, however I've been experience some wierd problems. After installing the RAID gui for windows that came on the epox driver cd, I was getting warnings galore approx. every 30sec-1min. Something about a failed port and it having to abort . Didn't like the sound of that at all so I tried reinstalling. Of course ran into the same problem as before with not wanting to format.

I tried deleting the raid set again and I switched the HD's cables (to make the new HD as the primary) and deleted and recreated the raid set. I have no idea if this does anything really but gave it a shot. Format failed on a 20 gig partition on the raid set. Tried the format again immediately after and it got stuck on something like 35% for an unusually long time (10-15 sec) then froze on 100 for about 15-20 sec but it let me install XP, so I was greatful of that. btw, these were all full formats. On the reboot from the very last windows xp update(SP1 installed fine) I got an error with file corruption (i think thats what it said) with something in C:\Windows\System\.

So I ran the win xp recovery off the cd and ran chkdsk. It reported one or more unfixable errors. This single run actually got me to the windows loading screen but as soon as i saw it, the computer would reboot. So I ran chkdsk once again and this time it said it found one or more errors and fixed them. I was pretty happy with this since windows would load fine now. However, there iss till one thing that's really bugging me. Wehn reading from the SATA, at times windows will lock up for about 10 seconds (no mouse movement, nothin).

I wanna say it's a hard drive issue but something tells me motherboard. One would suspect the first hard drive as the culprit since it was giving me problems inititally before the raid, however, the SI RAID gui is reporting the warnings on BOTH drives. Since the second chkdsk I haven't messed around with the pc much, just updated a few drivers, so i dont know how (un)stable it is yet. But I would also like to think a motherboard problem because my voltages are kind screwy. 12+ varies at times from 11.73-79 which seems a lil low to me. Also, when I try to set the vcore to 1.85, I get a reading of ~1.8. Also, pc was not stable (when running single sata) when dvd encoding with cce at stock settings/voltages. I had to boost the voltage to 1.7~1.75 to run stable. Any advice on what I should do from here out? Should I start the RMA process? If so, what should I start with.

loco 12th June, 2004 04:55 PM

does this new BIOS fixws the "Overclocking Failed" alerts?

Klavs 2nd August, 2004 10:45 AM

Same problem but this doesn't help
 
I have the same problem af KryaZeeZ here but the new beta BIOS doesn't seem to solve the problem. I'm installing Windows XP and making a full format on my RAID-0 setup with S-ATA drives. The S-ATA driverfile is version 1.0.0.28 from Epox.com/usa.

Anyone with good suggestions since I can't wait to get my new setup running.


All times are GMT +1. The time now is 12:29 PM.


Copyright ©2001 - 2010, AOA Forums


Search Engine Friendly URLs by vBSEO 3.3.0