AOA Forums

AOA Forums (http://www.aoaforums.com/forum/)
-   General Hardware Discussion (http://www.aoaforums.com/forum/7-general-hardware-discussion/)
-   -   Can't Format Hard Drives (http://www.aoaforums.com/forum/general-hardware-discussion/50732-cant-format-hard-drives.html)

booman 7th September, 2012 07:49 PM

Can't Format Hard Drives
 
I got to take an old Tower Server home and gut it.
I'm donating the motherboard/ram/CPU and keeping the case.
Last weekend I moved my Linux server hardware into the case and its GREAT! Much better than my old tower.

I wanted to format the old Maxtor IDE hard drives so I could use them, but I'm having a problem....
When connecting them via USB adapter with IDE connector, Windows and Linux won't allow me to format, delete or do anything.
They both show 0 bytes and can not even mount the drive.

The USB connection recognizes the drive but I can't modify all 3 of them in any way with Disk Management (Win) or Disk Utility (Linux).

What is the deal? I've never had this problem before?
Do you think there was some kind of encryption on the drives?
I tried different jumper settings but still locked out...

danrok 8th September, 2012 12:23 AM

Perhaps they are password protected.

Parallel ATA - Wikipedia, the free encyclopedia

booman 8th September, 2012 01:15 AM

Are you kidding me! I've never heard of this...
Kinda cool actually, but totally not neccesary in the server I got them from.
So now I have to learn how to pass a command to the drive???

danrok 8th September, 2012 01:29 AM

It's a possibility.

What kind of organisation owned these drives?

Do you have any drive tools which will tell you if the drives are protected?

booman 8th September, 2012 03:09 AM

Newspaper industry.
The server was a print server when it was last used. I really don't think there was sensitive data on it, but maybe 10 years ago when it was originally used there may have been.

Drive tools? Like hardware or software?
I can use the Disk Utility in Linux...

ThunderRd 8th September, 2012 04:41 PM

I think MHDD should indicate drive protection:

HDDGURU: MHDD

Daniel ~ 8th September, 2012 07:11 PM

Off the the wall...But you have an Acronis disk right? Use it to wipe the drive, fast will do... this has ended so many problems for me in the past.

Daniel ~ 8th September, 2012 07:13 PM

Disk utility should do what ever you want...I don't know a thing about encrypted or protected drives though

booman 8th September, 2012 09:23 PM

Thats what I'm saying... even disk utility won't format or delete the volumes/partitions.
So they must be locked....
I'll do some research on MHDD

Are you guys sure it's not a jumper issue? I am using a USB adapter, but its always worked on every drive I've plugged into it.

Aedan 9th September, 2012 08:42 AM

The ATA security (password protection) prevents you being able to read or write to the disks until the password is sent. If you attempt an operation, the drive would return a "drive not ready" error (same as if the disk has having problems reading).

However, if you can read anything that's on the disk, it's not likely to be protected.

USB adapters can bring their own issues, generally they can only issue read and write commands - things like ATA security aren't handled. Also, if the drive is very old, it might not understand some of the DMA modes that the USB adapter might be attempting to use.

booman 10th September, 2012 05:25 PM

Linux and Windows definitely says "drive not ready"
I'm pretty sure there is a password protection on these guys.
Sucks because I already donated the original motherboard.
So I can't even plug them in to the original hardware and format them.
But even if I could... the password would probably still exist because its in the firmware not the platters.

Aedan 10th September, 2012 05:40 PM

If they're password protected, then you're a bit out of luck I'm afraid. There are people who specialise in retrieving/deleting the password from the firmware, but they cost $$$.

booman 10th September, 2012 06:32 PM

do you think I could connect these in a different computer and try the password?
I know some of the standard passwords that might work...

Aedan 11th September, 2012 09:05 AM

Yeah, there's no reason not to. You'll need a motherboard that has BIOS support for ATA Security, which is the difficult part. Most laptops can manage that, but few desktops can. Desktops that are designed for corporate use are more likely to support the feature.

booman 11th September, 2012 05:38 PM

wow, I had no idea...
If I had known previously, I would have kept that motherboard. It was a cheap Pentium 4 motherboard, but I donated it with the processor and ECC RAM. I really have no use for it and I've already re-used the case.
That Sucks!:banghead:
At this point I'm giving up until I get another spare server/corporate workstation.
I don't even really need the hard drives, but they are nice for my refurbished builds.

Aedan 11th September, 2012 06:19 PM

Yeah, there's been one or two trojans in the past that have been able to activate the ATA Security features, because the motherboard BIOS doesn't deal with it correctly. Ideally a BIOS would check the ATA Security features, get the password if necessary, then apply a "Security Freeze", which stops any changes being made.

It's all extra code.

booman 11th September, 2012 07:13 PM

Trojans huh? so there IS a way!

Daniel ~ 12th September, 2012 02:04 AM

Cool it Boo you aren't even Greek!

booman 12th September, 2012 04:26 PM

I'm not really going to install a Trojan, but if those guys can figure it out, there must be a way.
I just want them formatted and ready-to-go

Aedan 12th September, 2012 05:30 PM

Other way around I'm afraid. It was a case that the trojan would set a password on your hard disk, and suddenly, you couldn't read it any longer. BIOSes that recognise ATA security set a flag on the drive preventing changes to the password, so it wasn't possible to set the password after booting.

booman 12th September, 2012 05:39 PM

still...
If a Trojan can reset the password and lock it out then there has to be a way to reset the password to nothing and unlock it...

Aedan 13th September, 2012 03:39 PM

The trojans can't reset the password. They can only set one if there isn't already one set (and therefore make your hard disk inaccessible).

Now, I do know that most hard disks have a serial debugging interface on them, and it is possible to issue commands to the controller over this channel. However, you'd need to get the commands out of the manufacturer for the controller (Good luck on that) , and figure out how to erase/bypass the password. Last time I screwed around with this kind of stuff I pretty much killed the drive.

chrisbard 14th September, 2012 12:00 AM

Throw em in the bin. Fast and reliable way of not losing anymore time.

booman 14th September, 2012 12:07 AM

Its starting to look like I don't have a choice

Daniel ~ 14th September, 2012 07:29 PM

I have a few hard drives I could let go of, what are you looking for?

booman 14th September, 2012 08:19 PM

I don't really need hard-drives per se, but I would never turn down a free one.
I'm a bit skeptical about shipping hard drives too. If you send one, make sure to get insurance because one drop from the mailman could kill it.

Daniel ~ 15th September, 2012 12:07 AM

I like to try and spot a need. Let me know if if you have a need.":O}

chrisbard 15th September, 2012 12:40 AM

Mailing HDD's with parked heads is OK. They are not as fragile as you might think in this condition.

chrisbard 15th September, 2012 12:41 AM

Quote:

Originally Posted by Daniel ~ (Post 519227)
I like to try and spot a need. Let me know if if you have a need.":O}

All you need is love! :D

Daniel ~ 15th September, 2012 12:47 AM

and a hard drive to put it on! ":O}

booman 15th September, 2012 02:30 PM

and to cuddle with...

Daniel ~ 15th September, 2012 05:46 PM

and to partition, but not until after your married...

booman 16th September, 2012 03:48 PM

Thats funny
I think I will take them apart and use the magnets on the fridge

Daniel ~ 16th September, 2012 06:32 PM

Now that's high level re-cycling! LOL

booman 17th September, 2012 05:06 PM

yup, its important to keep my girls drawings on the fridge!

Daniel ~ 17th September, 2012 11:00 PM

Feel free to share them here.

booman 17th September, 2012 11:32 PM

I might do that... I'll have to ask the wife first


All times are GMT +1. The time now is 07:08 AM.


Copyright ©2001 - 2010, AOA Forums


Search Engine Friendly URLs by vBSEO 3.3.0