AOA Forums

AOA Forums (http://www.aoaforums.com/forum/)
-   Graphics and Sound cards; Speakers and other Peripherals (http://www.aoaforums.com/forum/32-graphics-sound-cards-speakers-other-peripherals/)
-   -   Old nVidia cards - sluggish performance with Coolbits on (http://www.aoaforums.com/forum/graphics-sound-cards-speakers-other-peripherals/51400-old-nvidia-cards-sluggish-performance-coolbits.html)

trodas 6th June, 2015 11:38 PM

Old nVidia cards - sluggish performance with Coolbits on
 
For some old school fun and testings I sometimes overclock really old hardware, like FX 5600XT or FX 8600GT, FX 6800GS, FX 6800GT...

Now for the FX 5600XT card I use old beta Forceware 45.28 that I modifield slightly and using these Coolbits let me improve the performance by overclocking the card:

Code:

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak]
"CoolBits"=dword:0000000f
"NvCplEnableHardwarePage"=dword:00000001
"NvCplEnableAdditionalInfoPage"=dword:00000001
"NvCplEnableAGPSettingsPage"=dword:00000001

(the only important part for the clock adjustment is the "CoolBits"=dword:0000000f.

The performance scale nicely and all is good... except some more modern 3DMarks require more modern drivers to operate.

Surprisingly using the modern drivers AND Coolbit overclock result in sluggish performance. For example 3DMark03 goes from 2551 to 563 marks:
trodas`s 3DMark03 score: 2551 marks with a GeForce FX 5600 XT
trodas`s 3DMark03 score: 563 marks with a GeForce FX 5600 XT
Yes, on the Forceware v93.71 drivers I have a slightly different O/C (365/301 vs 370/305 on the old drivers), but nowhere near to "justify" such performance drop.

Now this is not specific on the 3DMark, all 3D apps go sluggish after using the Coolbits on more recent drivers. For example Aquamark3 - Forceware 61.76, stock 234/200: 13341 points: trodas`s Aquamark score: 13341 marks with a GeForce FX 5600 XT
Overclocked to 365/301 by Coolbits: 6640 points: trodas`s Aquamark score: 6640 marks with a GeForce FX 5600 XT

So there IS a dramatic slow-down, when I use more recent Forceware drivers (tried v61.76 and v93.71) AND Coolbits.

Same I observed on other mentioned videocards, like the FX 6800 and 8600 one, so it is not tied to the FX 5600XT only.


Therefore I look for more recent Coolbits, found there:
ForceWare Coolbits 2.0 download from Guru3D.com

Again, I used them at first completely, then removed them - for example that easily it could be done:

Code:

REGEDIT4
[-HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak]

...so I could strip them to the bare important for clock changes:

Code:

"CoolBits"=dword:ffffffff
Now this is different value that the 0000000f used before, so I hoped... and it caused the exactly same slow-downs. That make me a "bit" puzzled, so I started searching and I found third version of Coolbits:

Code:

"CoolBits"=dword:00000003
Coolbits - Wikipedia, the free encyclopedia

It probably won't be any surprise now, when I write that this once again enabled the O/C possibility, but caused sluggish performance.

...

So I give up on Coolbits and used Riva Tuner. It does work w/o reinstalling on new Windows, the O/C is limited to 355/300 (600 effective) and once again - after overclocking, the performance go bad. Slow. Terrible. Even some image quirks, at 355/300, when 370/306 works nicely with old drivers.

...

Now could anyone tell me, what is going wrong there? Why Coolbits / or any O/C in general, cause slow down of graphic?

I hoped I could find someone else who had the same problem years and years ago, I manage to find some threads where people appear to having the similar troubles:
Coolbits | PC Review
"I just overclocked the GPU a tiny bit, the frame rate and graphics slow down and become juddery"

...but that is too few results from my search... so perhaps I doing something wrong, like overoptimizing by disabling the nVidia help service or the startup programs that was put there by the nVidia drivers install...?
Once again - if I did not touch the overclocking, the performance is like it should be. After Coolbits = sluggish speed.

Or could it be, that any WHQ nVidia drivers lock-out the overclock by intentionaly slowing things down and I could only use beta drivers for overclock?! Could that be? And where to get some old beta drivers anyway? There are all WHQ ones, except one Quadro Beta Driver:
Windows XP/2000 Driver Archive | NVIDIA

Gizmo 7th June, 2015 05:48 PM

Only thing I can think of is that the old drivers might be doing a little less internally, and there's some kind of hardware timing constraint that is getting violated on the newer drivers?

trodas 13th June, 2015 04:01 PM

Dunno. But why this behaviour is consistent amont many cards? I start to belive that the nVidia drivers downloaded now does not intentionaly support overclocking.

Dunno why nVidia did this, but there is simply no other possibility. I have to look for my old backups for drivers that was not downloaded from nVidia site recently and then we know for sure. ATM there is only a strong suspiction of foul play on nVidia side.

Overclocking always worked pretty well for me, years and years ago!

Gizmo 14th June, 2015 11:35 PM

I seem to recall nVidia doing something along those lines a long time ago (inhibiting overclocking) but I don't know anything about them doing it recently.

tiamat63 17th June, 2015 06:31 PM

Quote:

Originally Posted by Gizmo (Post 526967)
I seem to recall nVidia doing something along those lines a long time ago (inhibiting overclocking) but I don't know anything about them doing it recently.

nV outright stripped anything carrying the 900m series from overclocking, that was just in February. Granted, that's a mobile GPU and I don't see the point and purpose. However the ability for the user to make those adjustments has been taken away.

As for the 5600XT -its been over a decade but I remember 'XT' being the value line and not clocking very well. I also remember tales of performance suffering when many did. Again, that was 10+ years ago.

cloasters 19th June, 2015 02:42 AM

Thank you tiamat63, most elucidating post!!

trodas 7th July, 2015 08:09 AM

So to be able to use Coolbits, one need to either get non blocking drivers, or modified drivers - that is sad. Overclocking always worked pretty well and straiggt-forward on nVidia and to learn, that these times are over and nVidia go directly against overclocking is a bit shocking to me.

Time to check on the AMD overclocking then.

tiamat63 31st July, 2015 06:47 PM

Quote:

Originally Posted by trodas (Post 527026)
So to be able to use Coolbits, one need to either get non blocking drivers, or modified drivers - that is sad. Overclocking always worked pretty well and straiggt-forward on nVidia and to learn, that these times are over and nVidia go directly against overclocking is a bit shocking to me.

Time to check on the AMD overclocking then.


Pretty sure TweakForce was still going strong last I checked. Its been quite a few years but I remember links on AoA to driver sets as well..?

It still creeps me out calling anything Radeon line AMD as opposed to ATI.
I don't think I'll ever get over that.


All times are GMT +1. The time now is 03:25 AM.


Copyright ©2001 - 2010, AOA Forums


Search Engine Friendly URLs by vBSEO 3.3.0