AOA Forums

AOA Forums (http://www.aoaforums.com/forum/)
-   Linux (http://www.aoaforums.com/forum/120-linux/)
-   -   I need help installing Nvidia driver in Fedora 11 64 bit please (http://www.aoaforums.com/forum/linux/48137-i-need-help-installing-nvidia-driver.html)

Daniel ~ 2nd November, 2009 08:07 PM

I need help installing Nvidia driver in Fedora 11 64 bit please
 
I think I said it all...?
A walk though would be greatly apprecated...":O}

chrisbard 2nd November, 2009 08:42 PM

Quote:

Originally Posted by Daniel ~ (Post 499674)
I think I said it all...?
A walk though would be greatly apprecated...":O}

1.Download nvdriver from internet
2.doubleclick on setup
3. click next next and finish
4. click on reboot now

Done.

Ohhh wait I forgot...that's the easy version for Windows! For Windows, get it? :rolling: :rolling: :rolling: Sorry man I couldn't help it. So you're telling me that linucs is so advanced you need a how to when installing a graphic driver? :rolling: :crazy: :eek:

Daniel ~ 2nd November, 2009 11:28 PM

Nope, I'm telling you Fedora is trying something new and I'm not liking it. In Mint 7 and Ubuntu you just install the OS and let it install Nvidia ...None of that sloppy windows stuff to deal with...":O}

danrok 3rd November, 2009 01:08 AM

Quote:

Originally Posted by chrisbard (Post 499675)
1.Download nvdriver from internet
2.doubleclick on setup
3. click next next and finish
4. click on reboot now

Done.

Ohhh wait I forgot...that's the easy version for Windows! For Windows, get it? :rolling: :rolling: :rolling: Sorry man I couldn't help it. So you're telling me that linucs is so advanced you need a how to when installing a graphic driver? :rolling: :crazy: :eek:

They had to make it really easy. Steve Ballmer needs to use it.

ThunderRd 3rd November, 2009 02:31 AM

I get the drivers from here:
Index of /packages/linux-nvidia/Linux-x86_64

or here:
Index of /packages/linux-nvidia/Linux-x86

depending on 32 or 64-bit install. The files are all named NVIDIA-something-something-something.run. The current driver is 190.42.

Then, I boot to a console, or alternately you can invoke a console from your GUI with alt-ctrl-F1. Then stop GNOME (you must be root, so use su or sudo or whatever Fedora uses):

Code:

/etc/init.d/gdm stop
Then navigate to the driver file and run it (again, you must be root):
Code:

sh /home/Daniel/Desktop/NAME-OF-DRIVER-FILE.run
If all goes properly, it will ask you if you want to write a new xorg file, say yes. It may also ask some other questions, just answer with the defaults.

For example, if it sees a previous driver install, it will want to remove it, but it will ask you first. It won't overwrite anything or remove anything without your permission (Chris - this is unlike Windows ;) ). You must allow it to remove the prior install to allow the current one, so say yes. You'll have to logoff or restart afterwards.

chrisbard 3rd November, 2009 07:39 AM

Quote:

Originally Posted by danrok (Post 499697)
They had to make it really easy. Steve Ballmer needs to use it.

This is why Windows is so popular even kids can install stuff on it ;)

PS Linucs is becoming more and more like windows (and I am not talking about the good stuff windows has)

chrisbard 3rd November, 2009 07:41 AM

Quote:

Originally Posted by ThunderRd (Post 499698)
For example, if it sees a previous driver install, it will want to remove it, but it will ask you first. It won't overwrite anything or remove anything without your permission (Chris - this is unlike Windows ;)

So let me se if I get your point; we were talking about graphic drivers and u tell me that its a bad thing that nvidia4windows overwrites stuff...like what, like older libraries of the old version of gdriver? Are you kidding? :rolling:

ThunderRd 3rd November, 2009 11:30 AM

Quote:

Originally Posted by chrisbard (Post 499713)
So let me se if I get your point; we were talking about graphic drivers and u tell me that its a bad thing that nvidia4windows overwrites stuff...like what, like older libraries of the old version of gdriver? Are you kidding? :rolling:

No, that wasn't what I was saying; but I'm *pretty* sure you know that. ;)

"We" were trying to help Daniel with his problem. "I" was trying to walk him through something. "I" also wrongly fell into baiting "you", which I will no longer do in future unless it's in an appropriate thread/forum.

This AOA Windows v Linux agenda is wearing thin, especially when it hijacks member's threads that are looking for legitimate help. I may be alone in that feeling, but I suspect I'm not.

"I" will no longer get involved unless it is in Random Nonsense, or in its own proper thread. That's where it belongs; it is healthy and fun there, and I quite enjoy it. It simply doesn't belong in other people's threads, and I apologize for any part I have played in it.

Now, can we get back to Daniel's problem? ;)

chrisbard 3rd November, 2009 12:23 PM

Awwww so my jokes are not funny anymore :(

OK no more jokes and threads hacking! :rolling:

chrisbard 3rd November, 2009 12:25 PM

I am sorry if I hurt your feeling guys !!! :eek:

dsio 3rd November, 2009 02:13 PM

Quote:

Originally Posted by chrisbard (Post 499719)
I am sorry if I hurt your feeling guys !!! :eek:

Penguins don't have feelings. They have feathers.

Feathers feel no pain.

Aedan 3rd November, 2009 03:09 PM

Quote:

Originally Posted by chrisbard (Post 499675)
1.Download nvdriver from internet
2.doubleclick on setup
3. click next next and finish
4. click on reboot now

That's a lot of steps! When I last installed a Linux box with an nVidia card it was:
  • 1. OS told me there was a better driver for my card, and offered to get it for me.
  • 2. Click on "OK"
  • 3. Click on Reboot and all is done.
Dunno what all this messing around with downloading files is for? Who needs a web browser?

Sorry Dan, this doesn't help you. However, I am getting to dislike Fedora 11 quite a bit.

chrisbard 3rd November, 2009 03:57 PM

Aedan I did not want to embarass fedora users completely. As you are aware nvidia has now integrated an autoupdate feature inside its ctrl panel. :rolleyes:

Daniel ~ 3rd November, 2009 07:32 PM

Thank you ThunderRD, much appreciated... I'll give it a try later today... Like Aedan I'm less impressed with Fedora 11 than I was with 10. Mint 7 still shines brightly for me as it give me no grief and everything works as it should...

Daniel ~ 3rd November, 2009 09:10 PM

Quote:

Originally Posted by ThunderRd (Post 499698)
I get the drivers from here:
Index of /packages/linux-nvidia/Linux-x86_64

or here:
Index of /packages/linux-nvidia/Linux-x86

depending on 32 or 64-bit install. The files are all named NVIDIA-something-something-something.run. The current driver is 190.42.

Then, I boot to a console, or alternately you can invoke a console from your GUI with alt-ctrl-F1. Then stop GNOME (you must be root, so use su or sudo or whatever Fedora uses):

Code:

/etc/init.d/gdm stop
Then navigate to the driver file and run it (again, you must be root):
Code:

sh /home/Daniel/Desktop/NAME-OF-DRIVER-FILE.run
If all goes properly, it will ask you if you want to write a new xorg file, say yes. It may also ask some other questions, just answer with the defaults.

For example, if it sees a previous driver install, it will want to remove it, but it will ask you first. It won't overwrite anything or remove anything without your permission (Chris - this is unlike Windows ;) ). You must allow it to remove the prior install to allow the current one, so say yes. You'll have to logoff or restart afterwards.

Hmmm.... I'm not getting very far with this... you may be over estimating my competence...I get that a lot! ":O}

When I try crt>alt> F1 nothing happens. That maybe the problem... also do I need all three files found ) The first and 1 and 2 Do I do them each in order?

[Daniel@localhost ~]$ su
Password:
[root@localhost Daniel]# /etc/init.d/gdm stop
bash: /etc/init.d/gdm: No such file or directory
[root@localhost Daniel]# /etc/init.d/gdm stop
bash: /etc/init.d/gdm: No such file or directory

[root@localhost Daniel]# sh /home/Daniel/Download/NVIDIA-Linux-x86_64-190.42-pkg0.run

ERROR: You appear to be running an X server; please exit X before
installing. For further details, please see the section INSTALLING
THE NVIDIA DRIVER in the README available on the Linux driver
download page at Welcome to NVIDIA - World Leader in Visual Computing Technologies.

OK

No hurry on this end as I mainly use Mint 7,,,just like to keep Fedora as up to date as I can...":O}

Daniel ~ 4th November, 2009 03:17 AM

Quote:

Originally Posted by chrisbard (Post 499712)

PS Linucs is becoming more and more like windows (and I am not talking about the good stuff windows has)

Except you don't have to pay for it or opplogize for using it..":O}

ThunderRd 4th November, 2009 03:17 AM

OK... it's complaining that gdm isn't stopped. In Debian and its friends you stop it the way I told you...

Can anyone tell Dan how to do it in Fedora? It may be something to do with run levels but I don't know how they work in Fedora.

In the meantime I'll try to look it up. I've just woken up for the day and won't have time til later, but you could try Googling for "how to stop gnome display manager fedora" or "how to stop x server fedora"...then it will install.

Do you have an option to boot to a console at the login screen? That might do it.

ThunderRd 4th November, 2009 03:29 AM

Daniel, try this.

You need to edit a file named /etc/initab as root.

Code:

nano -w /etc/initab
or you could use mousepad or whatever editor you like.

look for the line that starts with:

Code:

id:5:xxxxxxxxx
and change the "5" to a "3". Then reboot the box and it should go to a command line instead of a gui. Log in at the command line and try to install the drivers again. If you are successful, edit the "3" back to a "5" afterwards.

You need only one file. I use the most recent one, usually numbered pkg1 or pkg2. Also, it's not ctrl-alt-del you want, it's ctrl-alt-F1 to get a command line...

And no, I'm not overestimating your experience, I don't have experience on your distro and it's different from the methods I know, so I'm the problem here ;)

Another thing, do you know if you have the kernel source installed, or at least the headers? I'm not sure if this process works without...there's no harm done, though. It either will install and work, or it won't install at all.

Gizmo 4th November, 2009 03:41 AM

The best thing to do is to have Dan install the RPMFusion repo, and let it install and update his nVidia drivers automagically.


Dan, you need to click on the links below, in order, while running Firefox. Once you clicked on the link Firefox will ask you how to Open the file. Here you can simply use the default and open the file with the default application 'Package Installer'. Then Firefox will call Package Kit, which asks Do you want to install this file ?. Click OK to begin install; Package Kit then will complain about a Missing security signature; once you tell Package Kit to install the package nevertheless it will move on and install it. That's all.

you need to click on this link first: http://download1.rpmfusion.org/free/...ble.noarch.rpm

And this link second: http://download1.rpmfusion.org/nonfr...ble.noarch.rpm

After that, go to your terminal, su to root and then type:

yum install kmod-nvidia

That should pull in the latest 185.18.36 nvidia drivers for your kernel.

ThunderRd 4th November, 2009 03:50 AM

Nice one. I've always seemed to have problems installing Nvidia with a package manager in my rigs, and found this way kind of by accident. But I'm glad there's a better way for Fedora...


All times are GMT +1. The time now is 01:07 AM.


Copyright ©2001 - 2010, AOA Forums


Search Engine Friendly URLs by vBSEO 3.3.0