View Single Post
  #1 (permalink)  
Old 29th November, 2008, 04:04 PM
gedon's Avatar
gedon gedon is offline
Member
 
Join Date: November 2004
Posts: 446

Ubuntu raid setup

I need some help. I have attached a pic, so you can see whats going on on my desk
I throw some parts together and connected all my hdds to it.

You can see the abit anm2 with nvidia chipset (4 ports), a Sil3132 (2 ports), Promise S150 SX4 (4 ports), ide hdd and odd.
SATA hdds: 4 Hitachis (250GB) connected to nvidia, 4 Seagates (320GB) to Promise and 2 Samsungs (500GB) to Sil

My current status is that the Nvidia and Sil controllers operates in ide mode,
I have Ubuntu 8.10 AMD64 installed to one of the Hitachi drives and WinXP to ide hdd (I don't need XP anymore), all my files are on Hitachi and Samsung drives and the Seagate drives are empty.

At the end it should look like this:
IDE hdd: Ubuntu
2xSamsung: Raid 1
4xHitachi: Raid 5 or 0+1
4xSeagate: Raid 5 or 0+1

or this:
IDE hdd: Ubuntu
2xSamsung: Raid 0
4xHitachi: Raid 0
4xSeagate: Raid 5 or 0+1

I'd like to start with the Seagates and the Promise controller. I know this is not a hardware raid controller, but it has its own xor unit and cache. Is it even possible to get these several years old drivers from Promise for Suse or RedHat to work with Ubuntu? If not, linux supports the S150 SX4 but it doesn't use the xor unit or cache, that would be a big performance hit in raid 5.
It would be nice, if someone point me into the right direction.
Attached Thumbnails
Ubuntu raid setup-img_07892.jpg  
__________________

Last edited by gedon; 29th November, 2008 at 04:05 PM.
Reply With Quote