AOA Forums AOA Forums AOA Forums Folding For Team 45 AOA Files Home Front Page Become an AOA Subscriber! UserCP Calendar Memberlist FAQ Search Forum Home


Go Back   AOA Forums > Software > OS, Software, Firmware, and BIOS > Linux

Linux Questions and information concerning Linux


Reply
 
LinkBack Thread Tools Rate Thread
  #1 (permalink)  
Old 7th November, 2010, 12:33 PM
ThunderRd's Avatar
Irreverent Query Chairman
 
Join Date: June 2007
Location: NYC native in northern Thailand
Posts: 2,241

qt updates blocked in gentoo?

What do you make of this:

Code:
OPTERON-185 / # emerge -auvDNt world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge      ] x11-libs/qt-sql-4.6.3-r2  USE="exceptions iconv qt3support sqlite (-aqua) -debug (-firebird) -freetds -mysql -odbc -pch -postgres" 
[blocks b     ]  >x11-libs/qt-script-4.6.3-r9999 (">x11-libs/qt-script-4.6.3-r9999" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-dbus-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3)
[ebuild     U ]   x11-libs/qt-qt3support-4.7.0 [4.6.3] USE="accessibility exceptions (-aqua) -debug -kde -pch -phonon" 203,438 kB
[blocks b     ]  >x11-libs/qt-qt3support-4.6.3-r9999 (">x11-libs/qt-qt3support-4.6.3-r9999" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-dbus-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-script-4.6.3)
[ebuild     U ]   x11-libs/qt-sql-4.7.0 [4.6.3-r2] USE="exceptions iconv qt3support sqlite (-aqua) -debug (-firebird) -freetds -mysql -odbc -pch -postgres" 0 kB
[blocks b     ]    <x11-libs/qt-gui-4.7.0 ("<x11-libs/qt-gui-4.7.0" is blocking x11-libs/qt-qt3support-4.7.0, x11-libs/qt-script-4.7.0, x11-libs/qt-core-4.7.0, x11-libs/qt-dbus-4.7.0, x11-libs/qt-sql-4.7.0)
[ebuild     U ]     x11-libs/qt-gui-4.7.0-r1 [4.6.3] USE="accessibility cups dbus exceptions glib gtk mng qt3support raster* tiff (-aqua) -debug -egl% -nas -nis -pch -private-headers% -trace -xinerama" 0 kB
[blocks b     ]      <x11-libs/qt-dbus-4.7.0 ("<x11-libs/qt-dbus-4.7.0" is blocking x11-libs/qt-gui-4.7.0-r1, x11-libs/qt-qt3support-4.7.0, x11-libs/qt-script-4.7.0, x11-libs/qt-core-4.7.0, x11-libs/qt-sql-4.7.0)
[ebuild     U ]       x11-libs/qt-dbus-4.7.0 [4.6.3] USE="exceptions (-aqua) -debug -pch" 0 kB
[blocks b     ]        <x11-libs/qt-script-4.7.0 ("<x11-libs/qt-script-4.7.0" is blocking x11-libs/qt-qt3support-4.7.0, x11-libs/qt-gui-4.7.0-r1, x11-libs/qt-core-4.7.0, x11-libs/qt-dbus-4.7.0, x11-libs/qt-sql-4.7.0)
[ebuild     U ]         x11-libs/qt-script-4.7.0 [4.6.3] USE="exceptions iconv (-aqua) -debug -pch -private-headers%" 0 kB
[ebuild     U ]          x11-libs/qt-core-4.7.0 [4.6.3] USE="exceptions glib iconv qt3support ssl (-aqua) -debug -optimized-qmake -pch -private-headers% (-doc%)" 0 kB

Total: 6 packages (6 upgrades), Size of downloads: 203,438 kB
Conflict: 11 blocks

Would you like to merge these packages? [Yes/No]
I'm not sure what is happening here. I have had the odd blocked package before and dealt with it, but this seems unusual. Could it be related to the x11 overlay, and how should I resolve it if it is?
__________________
#1: Tt Armor, ASUS Maximus Extreme, QX9650@4.1G, 8G Corsair Dominator GT DDR3-2000, Corsair HX1050, H2O-Swiftech, Gigabyte GTX470/Arctic Accelero Xtreme Plus II, Intel 520 SSD, Kingston SSD, 2xRaptor 150G RAID0, Win 7 Pro 64
#2: Tt Shark, ASUS P5Q Pro Turbo, Q6600@3.8G, 4G HyperX-1600, Corsair HX850, CoolerMaster V10, 2xASUS 9600GT, 2xRaptor 74G RAID0, OCZ Vertex 4 SSD, Gentoo/siduction Linux [64-bit]
#3, #4: Opteron 170@2.75G nude, A8N-SLI Deluxe, Gentoo

AOA Folding @HomeOur sister site: www.gamersonlinux.com
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #2 (permalink)  
Old 7th November, 2010, 02:46 PM
Member
 
Join Date: April 2005
Location: AZ
Posts: 2,446

I believe it is the [nomerge] qt-sql that is causing the issue, but I am not sure why it is marked nomerge.

I would do an emerge -1 qt-sql, then give the auDN a another go.
__________________
Biostar TForce X58 - Core i7 920 - 12GB Corsair Dominator DDR3 - EVGA 560ti - PCP&C 750W - Dual boot, Arch Linux/WinXP
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #3 (permalink)  
Old 7th November, 2010, 03:14 PM
ThunderRd's Avatar
Irreverent Query Chairman
 
Join Date: June 2007
Location: NYC native in northern Thailand
Posts: 2,241

I don't understand the --oneshot argument. Doesn't that mean all the packages would be emerged? If they are, wouldn't the same problem exist?

Code:
OPTERON-185 / # emerge -pv -1 qt-sql

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] x11-libs/qt-core-4.7.0 [4.6.3] USE="exceptions glib iconv qt3support ssl (-aqua) -debug -optimized-qmake -pch -private-headers% (-doc%)" 203,438 kB
[ebuild     U ] x11-libs/qt-sql-4.7.0 [4.6.3-r2] USE="exceptions iconv qt3support sqlite (-aqua) -debug (-firebird) -freetds -mysql -odbc -pch -postgres" 0 kB
[blocks b     ] <x11-libs/qt-sql-4.7.0 ("<x11-libs/qt-sql-4.7.0" is blocking x11-libs/qt-qt3support-4.7.0, x11-libs/qt-gui-4.7.0-r1, x11-libs/qt-core-4.7.0, x11-libs/qt-dbus-4.7.0, x11-libs/qt-script-4.7.0)
[ebuild     U ] x11-libs/qt-script-4.7.0 [4.6.3] USE="exceptions iconv (-aqua) -debug -pch -private-headers%" 0 kB
[blocks b     ] <x11-libs/qt-script-4.7.0 ("<x11-libs/qt-script-4.7.0" is blocking x11-libs/qt-qt3support-4.7.0, x11-libs/qt-gui-4.7.0-r1, x11-libs/qt-core-4.7.0, x11-libs/qt-dbus-4.7.0, x11-libs/qt-sql-4.7.0)
[ebuild     U ] x11-libs/qt-dbus-4.7.0 [4.6.3] USE="exceptions (-aqua) -debug -pch" 0 kB
[blocks b     ] <x11-libs/qt-dbus-4.7.0 ("<x11-libs/qt-dbus-4.7.0" is blocking x11-libs/qt-gui-4.7.0-r1, x11-libs/qt-qt3support-4.7.0, x11-libs/qt-script-4.7.0, x11-libs/qt-core-4.7.0, x11-libs/qt-sql-4.7.0)
[ebuild     U ] x11-libs/qt-gui-4.7.0-r1 [4.6.3] USE="accessibility cups dbus exceptions glib gtk mng qt3support raster* tiff (-aqua) -debug -egl% -nas -nis -pch -private-headers% -trace -xinerama" 0 kB
[blocks b     ] <x11-libs/qt-gui-4.7.0 ("<x11-libs/qt-gui-4.7.0" is blocking x11-libs/qt-qt3support-4.7.0, x11-libs/qt-script-4.7.0, x11-libs/qt-core-4.7.0, x11-libs/qt-dbus-4.7.0, x11-libs/qt-sql-4.7.0)
[blocks b     ] >x11-libs/qt-qt3support-4.6.3-r9999 (">x11-libs/qt-qt3support-4.6.3-r9999" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-dbus-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-script-4.6.3)
[ebuild     U ] x11-libs/qt-qt3support-4.7.0 [4.6.3] USE="accessibility exceptions (-aqua) -debug -kde -pch -phonon" 0 kB
[blocks b     ] >x11-libs/qt-script-4.6.3-r9999 (">x11-libs/qt-script-4.6.3-r9999" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-dbus-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3)
[blocks b     ] >x11-libs/qt-core-4.6.3-r9999 (">x11-libs/qt-core-4.6.3-r9999" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-dbus-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-script-4.6.3)
[blocks b     ] >x11-libs/qt-sql-4.6.3-r9999 (">x11-libs/qt-sql-4.6.3-r9999" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-script-4.6.3)
[blocks b     ] <x11-libs/qt-qt3support-4.7.0 ("<x11-libs/qt-qt3support-4.7.0" is blocking x11-libs/qt-gui-4.7.0-r1, x11-libs/qt-script-4.7.0, x11-libs/qt-core-4.7.0, x11-libs/qt-dbus-4.7.0, x11-libs/qt-sql-4.7.0)
[blocks b     ] >x11-libs/qt-gui-4.6.3-r9999 (">x11-libs/qt-gui-4.6.3-r9999" is blocking x11-libs/qt-dbus-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-script-4.6.3)
[blocks b     ] >x11-libs/qt-dbus-4.6.3-r9999 (">x11-libs/qt-dbus-4.6.3-r9999" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-script-4.6.3)

Total: 6 packages (6 upgrades), Size of downloads: 203,438 kB
Conflict: 11 blocks

Would you like to merge these packages? [Yes/No]
__________________
#1: Tt Armor, ASUS Maximus Extreme, QX9650@4.1G, 8G Corsair Dominator GT DDR3-2000, Corsair HX1050, H2O-Swiftech, Gigabyte GTX470/Arctic Accelero Xtreme Plus II, Intel 520 SSD, Kingston SSD, 2xRaptor 150G RAID0, Win 7 Pro 64
#2: Tt Shark, ASUS P5Q Pro Turbo, Q6600@3.8G, 4G HyperX-1600, Corsair HX850, CoolerMaster V10, 2xASUS 9600GT, 2xRaptor 74G RAID0, OCZ Vertex 4 SSD, Gentoo/siduction Linux [64-bit]
#3, #4: Opteron 170@2.75G nude, A8N-SLI Deluxe, Gentoo

AOA Folding @HomeOur sister site: www.gamersonlinux.com

Last edited by ThunderRd; 7th November, 2010 at 03:18 PM.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #4 (permalink)  
Old 7th November, 2010, 03:16 PM
Kaitain's Avatar
Member
Mars Rover Champion, Joust Champion
 
Join Date: September 2001
Location: MK10, UK.
Posts: 4,372
Send a message via MSN to Kaitain Send a message via Skype™ to Kaitain

When updating a decimal point in qt (e.g. 4.5 to 4.6) I usually find it less painful to unmerge the entire qt set, emerge the new version then run a revdep-rebuild to pick up broken dependencies.

It takes a lot less time than resolving all of qt's blocking issues between point versions...
__________________
It is by coffee alone I set my mind in motion...
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #5 (permalink)  
Old 7th November, 2010, 03:17 PM
Kaitain's Avatar
Member
Mars Rover Champion, Joust Champion
 
Join Date: September 2001
Location: MK10, UK.
Posts: 4,372
Send a message via MSN to Kaitain Send a message via Skype™ to Kaitain

--oneshot means it's not recorded in your world file, so portage won't keep pestering you with updates. Useful for commercial software with ebuilds or for sorting out blocks.
__________________
It is by coffee alone I set my mind in motion...
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #6 (permalink)  
Old 7th November, 2010, 03:32 PM
ThunderRd's Avatar
Irreverent Query Chairman
 
Join Date: June 2007
Location: NYC native in northern Thailand
Posts: 2,241

I'm going to image the drive now, and try it both ways to see what I can learn.

Back in a few shakes.
__________________
#1: Tt Armor, ASUS Maximus Extreme, QX9650@4.1G, 8G Corsair Dominator GT DDR3-2000, Corsair HX1050, H2O-Swiftech, Gigabyte GTX470/Arctic Accelero Xtreme Plus II, Intel 520 SSD, Kingston SSD, 2xRaptor 150G RAID0, Win 7 Pro 64
#2: Tt Shark, ASUS P5Q Pro Turbo, Q6600@3.8G, 4G HyperX-1600, Corsair HX850, CoolerMaster V10, 2xASUS 9600GT, 2xRaptor 74G RAID0, OCZ Vertex 4 SSD, Gentoo/siduction Linux [64-bit]
#3, #4: Opteron 170@2.75G nude, A8N-SLI Deluxe, Gentoo

AOA Folding @HomeOur sister site: www.gamersonlinux.com
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #7 (permalink)  
Old 7th November, 2010, 03:46 PM
Member
 
Join Date: April 2005
Location: AZ
Posts: 2,446

For the most part portage is pretty smart, you will run into blocks here and there. If it will allow you to emerge the packages it will normally emerge them in an order that replaces the blocking packages allowing it to update the next package and removing another blocker.

I replied the first time before I had my coffee, but normally in that situation I would just emerge the most offending package and update world, letting portage handle the work.
__________________
Biostar TForce X58 - Core i7 920 - 12GB Corsair Dominator DDR3 - EVGA 560ti - PCP&C 750W - Dual boot, Arch Linux/WinXP

Last edited by ccperf721p; 7th November, 2010 at 03:49 PM.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #8 (permalink)  
Old 7th November, 2010, 06:12 PM
ThunderRd's Avatar
Irreverent Query Chairman
 
Join Date: June 2007
Location: NYC native in northern Thailand
Posts: 2,241

Well, that seemed to work - using 'emerge -1 qt-sql' emerged qt-core first, then qt-sql afterwards, followed by the other four updates. uDN didn't yield any other problems, and there weren't any emerge errors, so I guess it's happy.

Now, if what K* says is correct, these packages haven't been recorded in the world file. Is that what I want, or should I take some action here to insure that they get updated later?
__________________
#1: Tt Armor, ASUS Maximus Extreme, QX9650@4.1G, 8G Corsair Dominator GT DDR3-2000, Corsair HX1050, H2O-Swiftech, Gigabyte GTX470/Arctic Accelero Xtreme Plus II, Intel 520 SSD, Kingston SSD, 2xRaptor 150G RAID0, Win 7 Pro 64
#2: Tt Shark, ASUS P5Q Pro Turbo, Q6600@3.8G, 4G HyperX-1600, Corsair HX850, CoolerMaster V10, 2xASUS 9600GT, 2xRaptor 74G RAID0, OCZ Vertex 4 SSD, Gentoo/siduction Linux [64-bit]
#3, #4: Opteron 170@2.75G nude, A8N-SLI Deluxe, Gentoo

AOA Folding @HomeOur sister site: www.gamersonlinux.com
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #9 (permalink)  
Old 7th November, 2010, 07:51 PM
Member
 
Join Date: April 2005
Location: AZ
Posts: 2,446

qt-sql is or should be a dep of qt-something so it will be updated with other items that depend on it.

Edit: The only things you want in your world file are applications you specifically installed, you don't want dependancies to be recorded in the world file. Portage will still keep track of all software on your system and update it regardless of whether it is in world or not. You probably already know but the world file is locate at /var/lib/portage/world. It can be edited by hand just as well if need be.
__________________
Biostar TForce X58 - Core i7 920 - 12GB Corsair Dominator DDR3 - EVGA 560ti - PCP&C 750W - Dual boot, Arch Linux/WinXP

Last edited by ccperf721p; 8th November, 2010 at 01:52 AM.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #10 (permalink)  
Old 8th November, 2010, 07:01 AM
ThunderRd's Avatar
Irreverent Query Chairman
 
Join Date: June 2007
Location: NYC native in northern Thailand
Posts: 2,241

Now I understand why --oneshot is used. Thanks for the explanation
__________________
#1: Tt Armor, ASUS Maximus Extreme, QX9650@4.1G, 8G Corsair Dominator GT DDR3-2000, Corsair HX1050, H2O-Swiftech, Gigabyte GTX470/Arctic Accelero Xtreme Plus II, Intel 520 SSD, Kingston SSD, 2xRaptor 150G RAID0, Win 7 Pro 64
#2: Tt Shark, ASUS P5Q Pro Turbo, Q6600@3.8G, 4G HyperX-1600, Corsair HX850, CoolerMaster V10, 2xASUS 9600GT, 2xRaptor 74G RAID0, OCZ Vertex 4 SSD, Gentoo/siduction Linux [64-bit]
#3, #4: Opteron 170@2.75G nude, A8N-SLI Deluxe, Gentoo

AOA Folding @HomeOur sister site: www.gamersonlinux.com
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
signature blocked Graywolves Forum Feedback and Suggestion Box 3 21st June, 2010 08:11 PM
Grrr P2P programs blocked. IceRaptor Mobile Devices and Networking 16 1st October, 2007 10:24 AM
How to access blocked websites - Top 10 danrok Data Security 4 5th January, 2007 02:57 PM
Quotes are blocked/highlited? Pinky Forum Feedback and Suggestion Box 12 21st May, 2002 09:03 PM
Epox 8kha+ blocked on FF code Spin0ne EPoX MotherBoards 8 9th January, 2002 11:34 PM


All times are GMT +1. The time now is 12:31 AM.


Copyright ©2001 - 2010, AOA Forums
Don't Click Here Don't Click Here Either

Search Engine Friendly URLs by vBSEO 3.3.0