AOA Forums

AOA Forums (http://www.aoaforums.com/forum/index.php)
-   OS, Software, Firmware, and BIOS (http://www.aoaforums.com/forum/forumdisplay.php?f=12)
-   -   SuSE Linux problem! (http://www.aoaforums.com/forum/showthread.php?t=37734)

NarkotikBuzz 16th August, 2006 02:42 PM

SuSE Linux problem!
 
I am having a strange issue with SuSE. i used the YaST installer to install all of the updates which went fine, but then when i use it to install the latest nvidia drivers, it does that, but then when i reboot, it wont start the desktop, it tells me that level 5 was skipped and it gives me a login prompt, followed by a blinking cursor? I have no idea what to do. I tried erasing the partition and reinstalling Fedora Core 5, but after i am done with that, and i reboot, it tells me "GRUB error 17", which i have no idea what that means. How do i just blank all this out, get rid of GRUB and start over.:banghead:

robbie 16th August, 2006 02:46 PM

You can used (window's) Fdisk to 86 the linux partition and start all over with linux if you like.

dsio 16th August, 2006 02:48 PM

Telling you how to make it work under SuSE would have been easy, just login and vi your /etc/inittab to change runlevel 3 to runlevel 5 then save and reboot.

Use the linux CD to remove all linux partitions and install Fedora Core 5 in its place (you could do SuSE again, but I can much more easily help you with Fedora if you need it).

Everyone that tries linux nukes their partition in frustration a few times. Its normal.

NarkotikBuzz 16th August, 2006 02:55 PM

The only problem is i have tried to erase all the linux partitions and reinstall Fedora, but then it tells me "GRUB error 17" and does nothing.....i have to reboot then to windows, or try reinstalling linux. If i am gonna reinstall Fedora, which i would like to do, i have to get rid of GRUB first, how do i reset the bootloader to nothing. I read somewhere that i can boot with the windows disk, then go into "r" to repair, then type "fixmbr", but i have not tried it yet so i dont know if it will work. All i know is that " GRUB " has to go.

dsio 16th August, 2006 02:58 PM

OK, so you are talking about removing GRUB from the windows partition?

Yea, that can be fixed by a windows repair off the original disk, and an MBR repair.

NarkotikBuzz 16th August, 2006 03:06 PM

I will give it a try in a while and let you know how it goes.

Redroar 16th August, 2006 03:50 PM

I believe the command for putting the windows bootloader on is

fixboot /fixmbr

That will remove GRUB and should allow you to install Linux again with no problems. What I can't believe is that just last night, the exact same thing happened to me. Well, I had no problem with video drivers, but I saw someone using Ubuntu and liked it, so I got an installation CD and formatted Fedora Core. Whoops, looks like there were important GRUB files on that partition. This is bad, can't get into windows. Well, I install Ubuntu, and now GRUB's working, but when I try to boot Ubuntu, it fails to mount the root filesystem. Well, I format it again, and reinstall Fedora Core. GRUB's working, Fedora's working (typing from it right now!), and all is well in the world.

NarkotikBuzz 17th August, 2006 03:11 PM

OK, so i got rid of GRUB, and reinstalled Fedora, and it all went fine, and then it told me to reboot, well i expected to get a boot loader screen asking what i wanted to boot, but alas, all it did was boot straight to windows, it never even asked me if i wanted to boot linux, and so now i have no idea why it wont ask me if i want to boot linux. It acts like linux doesnt exist. I even tried holding F8 while booting, and going to the list of OS, and it only lists windows, so i am at a loss guys. When i look at my second drive in partition magic, which has my linux partition on it, all it says for the whole disk is "BAD". I even tried to format it through partition magic, and it comes up with an error message and wont format it. The disk acts fine, i can access all the windows files on it just fine so i dont know what the problem is. Please help.:banghead:

dsio 17th August, 2006 03:15 PM

Well are you using two hard disks here, or just one hard disk with two partitions on it?

NarkotikBuzz 17th August, 2006 03:18 PM

I have 2 hard disks, c: has windows on it and E: has 20Gb for NTFS, and 20Gb for Linux.

dsio 17th August, 2006 03:22 PM

Which disk have you set to your primary booting disk in bios?

NarkotikBuzz 17th August, 2006 03:25 PM

I have it set to boot from C: first, but when i installed Fedora, it told me i was installing GRUB, and it asked me which default OS to boot, and it said it would splash a boot loader screen where i could choose which to load. It did the same thing in SuSE, but now nothing.

dsio 17th August, 2006 03:42 PM

I think you installed GRUB on the second hard disk, so you need to set it to boot of E:

NarkotikBuzz 17th August, 2006 03:55 PM

I will give it a try and see what happens.

NarkotikBuzz 17th August, 2006 04:01 PM

Nope, that didnt work, it said "Error loading OS"......so i am at a total loss on this one.:confused:

Redroar 17th August, 2006 05:31 PM

It won't format? That's weird. It's true, GRUB will likely install on the disk Fedora is on unless otherwise specified. Here's my suggestion though. I was reading, and apparently there's a way you can set up the Windows bootloader to be able to choose which OS to boot. I'm not exactly sure how you do it for Linux, but it's worth some research. That may work better than GRUB.

NarkotikBuzz 18th August, 2006 01:01 AM

Well, i have given up for now, i have erased all the partitions and started over. I will install linux at a later date, i am just frustrated with it for now.................:banghead: :banghead: :mad: :banghead: :mad: :crazy:

Kaitain 18th August, 2006 08:47 PM

Quote:

Originally Posted by dsio
Telling you how to make it work under SuSE would have been easy, just login and vi your /etc/inittab to change runlevel 3 to runlevel 5 then save and reboot.

Not true - the initial problem was that "runlevel 5 was skipped". This means that SuSE screwed up building the nvidia rpm again.

In future, tell YaST never to update the nvidia rpm and always get .run file from nvidia.com. We'll explain how to run the nvidia binary some other time.

To repair the bootloader would've been a matter of using the SuSE install CD, or the Gentoo one, or Knoppix, or any other decent LiveCD, then (as root) typing:

grub
root (hd0,0)
setup (hd0)
quit

then hit the reset button.

WindowsXP is now capable of scrubbing Linux partitions of a drive if you mess it up. Just use Windows to delete the partition and all its contents, then set up a Windows partition on top of it. This also helps the barking mad SuSE installer that insists on shrinking or deleting Windows partitions instead of identifying and using free space on hard discs.

<the grouch will now retire back under his rock muttering something about having erased linux, permanently, for good, because half-arsed operating systems written by students are a waste of time>

NarkotikBuzz 19th August, 2006 11:27 AM

I got rid of linux and merged the two partitions on my E: drive. It made what used to be the linux partition into a folder on the E: drive, but when i click on the folder in explorer in tells me "Access denied", whats up with that?

Snakedriver 2nd September, 2006 02:44 AM

Quote:

Originally Posted by NarkotikBuzz
I got rid of linux and merged the two partitions on my E: drive. It made what used to be the linux partition into a folder on the E: drive, but when i click on the folder in explorer in tells me "Access denied", whats up with that?

It is a linux file system; windows can't read it!

The next time you install SuSe after the 1st reboot to finish the install, you can then install the nvidia video drivers for 3D. The easiest way to get them config'd is to reboot & at the boot splash type "level 3" which will boot you to runlevel 3 and a command line. Login as root. Type "sax2 -r -m 0=nvidia" (0 is a zero). Sax2 will start & you can configure the video card & monitor. Always test, use ctrl+alt+backspace to recover if it's a garbbled screen, select another set, retest, etc., save, reboot. 3d will be enabled. BTW, nvidia has a new set of linux drivers, there is a link to a SuSe howto on the download page.

On Grub setup. During the install, select "Expert" on the page where you do partitioning & software; this brings up the Grub context where you can select what disk/partition & can edit the menu which will become /boot/grub/menu.lst. I recommend writing it to the mbr. You can always recover windows with repair & "fixmbr" if need be.

Snakedriver @ www.suseforums.net
SuSe 10.1 x86-64 on EP MF570SLI am2 w/ x2 4800+; doing 100%


All times are GMT +1. The time now is 12:07 AM.


Copyright ©2001 - 2010, AOA Forums


Search Engine Friendly URLs by vBSEO 3.3.0